re = /(?<=temp_min:)[^ ]+/m
str = 'speed:10 temp_min:-14 temp_max:10
speed:5 temp_min:-12 temp_max:10 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end