using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https?:\/\/)?([\w\-\.]*)?((?:[\w-]*\/)*)(\w+\.\w+)?(\?.*)?$";
string input = @"/_d/assets/bifocal/themes/read/planeta/main.js
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/_d/openbook.json
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/portada.htm?cmpt=eyJzcGluZSI6MH0=--e2876ee89281460bea1897f7a52c8031aeefe2d1
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/images/logo_b.jpg
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}