import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?:\\/\\/)?([\\w\\-\\.]*)?((?:[\\w-]*\\/)*)(\\w+\\.\\w+)?(\\?.*)?$";
final String string = "/_d/assets/bifocal/themes/read/planeta/main.js\n"
+ "https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/\n"
+ "https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/_d/openbook.json\n"
+ "https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/portada.htm?cmpt=eyJzcGluZSI6MH0=--e2876ee89281460bea1897f7a52c8031aeefe2d1\n"
+ "https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/images/logo_b.jpg\n"
+ "https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}