package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https?:\/\/)?([\w\-\.]*)?((?:[\w-]*\/)*)(\w+\.\w+)?(\?.*)?$`)
var str = `/_d/assets/bifocal/themes/read/planeta/main.js
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/_d/openbook.json
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/portada.htm?cmpt=eyJzcGluZSI6MH0=--e2876ee89281460bea1897f7a52c8031aeefe2d1
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/images/logo_b.jpg
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}