using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"~~(?=.+#include)";
string input = @"kWordSyntaxSearch = ""something~~abc#include"";
kWordSyntaxSearch = ""something~~a bc#include"";
kWordSyntaxSearch = ""something~~ abc#include"";
kWordSyntaxSearch = ""something~~abc #include"";
kWordSyntaxSearch = ""something~~#include"";";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}