re = /~~(?=.+#include)/
str = 'kWordSyntaxSearch = "something~~abc#include";
kWordSyntaxSearch = "something~~a bc#include";
kWordSyntaxSearch = "something~~ abc#include";
kWordSyntaxSearch = "something~~abc #include";
kWordSyntaxSearch = "something~~#include";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end