$re = '/~~(?=.+#include)/';
$str = 'kWordSyntaxSearch = "something~~abc#include";
kWordSyntaxSearch = "something~~a bc#include";
kWordSyntaxSearch = "something~~ abc#include";
kWordSyntaxSearch = "something~~abc #include";
kWordSyntaxSearch = "something~~#include";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);