using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[1-9]\d*(\.\d+)?([\+\-\*\/]\d+(\.\d+)?)*\+$";
string substitution = @"$1-$2";
string input = @"1";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}