re = /^[1-9]\d*(\.\d+)?([\+\-\*\/]\d+(\.\d+)?)*\+$/
str = '1'
subst = '$1-$2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result