import re
regex = re.compile(r"^[1-9]\d*(\.\d+)?([\+\-\*\/]\d+(\.\d+)?)*\+$")
test_str = "1"
subst = "$1-$2"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)