const regex = /(select top [0-9]+ percent|select top [0-9]+|select )/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(select top [0-9]+ percent|select top [0-9]+|select )', 'ig')
const str = `seLect top 21 campo, campo from tabela select top 100 percent teste 2 top `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}