#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?=.*\b\d[a-z\d]*\b)(?:\b[a-z\d]+\b[ \t]*){2,}$"
Local $sString = "5413 Flat" & @CRLF & _
"3rd Street" & @CRLF & _
"562test test" & @CRLF & _
"test 5415" & @CRLF & _
"test 5test" & @CRLF & _
"" & @CRLF & _
"1234" & @CRLF & _
"test5 test" & @CRLF & _
"te5st test" & @CRLF & _
"test te5st" & @CRLF & _
"test test55"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")