const regex = /^(?=.*\b\d[a-z\d]*\b)(?:\b[a-z\d]+\b[ \t]*){2,}$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*\\b\\d[a-z\\d]*\\b)(?:\\b[a-z\\d]+\\b[ \\t]*){2,}$', 'gmi')
const str = `5413 Flat
3rd Street
562test test
test 5415
test 5test
1234
test5 test
te5st test
test te5st
test test55`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}