$re = '/^(?=.*\b\d[a-z\d]*\b)(?:\b[a-z\d]+\b[ \t]*){2,}$/mi';
$str = '5413 Flat
3rd Street
562test test
test 5415
test 5test
1234
test5 test
te5st test
test te5st
test test55';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);