import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:#|\\/\\/)(.*?)|\\/\\*((?:.|\\n)*?)\\*\\/)*\\n*?\\b(.*?)\\((.*?)\\);";
final String string = "#hello world calling\n\n"
+ "hello_world();\n\n"
+ "============================\n"
+ "//hello world calling\n\n"
+ "hello_world('hello');\n"
+ "==========================\n"
+ "/*\n"
+ " Hello World Calling\n"
+ " multiline comment\n"
+ "*/\n\n"
+ "hello_world('hello','world');\n\n"
+ "hello_world('hello','world','anything');";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}