$re = '/(?:(?:#|\/\/)(.*?)|\/\*((?:.|\n)*?)\*\/)*\n*?\b(.*?)\((.*?)\);/';
$str = '#hello world calling
hello_world();
============================
//hello world calling
hello_world(\'hello\');
==========================
/*
Hello World Calling
multiline comment
*/
hello_world(\'hello\',\'world\');
hello_world(\'hello\',\'world\',\'anything\');';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);