const regex = /(?:(?:#|\/\/)(.*?)|\/\*((?:.|\n)*?)\*\/)*\n*?\b(.*?)\((.*?)\);/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:#|\\\/\\\/)(.*?)|\\\/\\*((?:.|\\n)*?)\\*\\\/)*\\n*?\\b(.*?)\\((.*?)\\);', 'g')
const str = `#hello world calling
hello_world();
============================
//hello world calling
hello_world('hello');
==========================
/*
Hello World Calling
multiline comment
*/
hello_world('hello','world');
hello_world('hello','world','anything');`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}