const regex = /\s(.*)\.gpkg$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s(.*)\\.gpkg$', 'gm')
const str = `[2021-05-14 11:15:18 CEST] 136KiB testdit.gpkg
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}