use strict;
my $str = 'root 111 /sbin/ksh
root24 1 -bash
root 111 /ksh/init
root11 345 ksh
aaaa 123 /a/n/g/h';
my $regex = qr/^(\w+)\s+(\w+)[\w\/-]*[-\/](\w+)$/mp;
my $subst = '\\\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";