import Foundation
let pattern = #"^(\w+)\s+(\w+)[\w\/-]*[-\/](\w+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
root 111 /sbin/ksh
root24 1 -bash
root 111 /ksh/init
root11 345 ksh
aaaa 123 /a/n/g/h
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)