re = /^(\w+)\s+(\w+)[\w\/-]*[-\/](\w+)$/m
str = 'root 111 /sbin/ksh
root24 1 -bash
root 111 /ksh/init
root11 345 ksh
aaaa 123 /a/n/g/h'
subst = '\\\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result