import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img([^>]*)src=\"[(([^:\"]*)(\\{png|gif|jpg|jpeg\\}))]\"";
final String string = "<!DOCTYPE html>\n"
+ "<html>\n"
+ "<body>\n\n"
+ "<img src=\"smiley.gif\" alt=\"Smiley face\" height=\"42\" width=\"42\" style=\"float:right\">\n\n"
+ "<p>Insert an image from another folder:</p>\n"
+ "<img src=\"/images/stickman.gif\" alt=\"Stickman\" width=\"24\" height=\"39\">\n\n"
+ "<p style=\"float:left\">Insert an image from a web site:</p>\n"
+ "<img style=\"color:green; float:right;\" src=\"http://www.w3schools.com/images/lamp.gif\" alt=\"Lamp\" width=\"15\" height=\"15\">\n\n"
+ "</body>\n"
+ "</html>\n";
final String subst = "<img \\2";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}