const regex = /<img([^>]*)src="[(([^:"]*)({png|gif|jpg|jpeg}))]"/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img([^>]*)src="[(([^:"]*)({png|gif|jpg|jpeg}))]"', 'img')
const str = `<!DOCTYPE html>
<html>
<body>
<img src="smiley.gif" alt="Smiley face" height="42" width="42" style="float:right">
<p>Insert an image from another folder:</p>
<img src="/images/stickman.gif" alt="Stickman" width="24" height="39">
<p style="float:left">Insert an image from a web site:</p>
<img style="color:green; float:right;" src="http://www.w3schools.com/images/lamp.gif" alt="Lamp" width="15" height="15">
</body>
</html>
`;
const subst = `<img \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);