# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<img([^>]*)src=\"[(([^:\"]*)({png|gif|jpg|jpeg}))]\""
test_str = ("<!DOCTYPE html>\n"
"<html>\n"
"<body>\n\n"
"<img src=\"smiley.gif\" alt=\"Smiley face\" height=\"42\" width=\"42\" style=\"float:right\">\n\n"
"<p>Insert an image from another folder:</p>\n"
"<img src=\"/images/stickman.gif\" alt=\"Stickman\" width=\"24\" height=\"39\">\n\n"
"<p style=\"float:left\">Insert an image from a web site:</p>\n"
"<img style=\"color:green; float:right;\" src=\"http://www.w3schools.com/images/lamp.gif\" alt=\"Lamp\" width=\"15\" height=\"15\">\n\n"
"</body>\n"
"</html>\n")
subst = "<img \\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.