#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miS)^edit\s(.*?)\s\;mode[\S\s]*?(?=.*?\b(KeyWord_1|KeyWord_2|KeyWord_3|NonExistant_1)\b)(?=.*?\b(1|2|3|A|B|C|8|9|10|X|Y\Z)\b)[\S\s]*?exit$"
Local $sString = "edit GoodMatch1 ;mode" & @CRLF & _
"Something Random" & @CRLF & _
"KeyWord_2 A B and C and also D E" & @CRLF & _
"Something Random" & @CRLF & _
"Something Random" & @CRLF & _
"KeyWord_3 1 A and 2 B" & @CRLF & _
"Something Random" & @CRLF & _
"KeyWord_1 1 2 and 3 and also 4 5" & @CRLF & _
"Something Random" & @CRLF & _
"exit"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")