const regex = /^edit\s(.*?)\s\;mode[\S\s]*?(?=.*?\b(KeyWord_1|KeyWord_2|KeyWord_3|NonExistant_1)\b)(?=.*?\b(1|2|3|A|B|C|8|9|10|X|Y\Z)\b)[\S\s]*?exit$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^edit\\s(.*?)\\s\\;mode[\\S\\s]*?(?=.*?\\b(KeyWord_1|KeyWord_2|KeyWord_3|NonExistant_1)\\b)(?=.*?\\b(1|2|3|A|B|C|8|9|10|X|Y\\Z)\\b)[\\S\\s]*?exit$', 'gmi')
const str = `edit GoodMatch1 ;mode
Something Random
KeyWord_2 A B and C and also D E
Something Random
Something Random
KeyWord_3 1 A and 2 B
Something Random
KeyWord_1 1 2 and 3 and also 4 5
Something Random
exit`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}