using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^edit\s(.*?)\s\;mode[\S\s]*?(?=.*?\b(KeyWord_1|KeyWord_2|KeyWord_3|NonExistant_1)\b)(?=.*?\b(1|2|3|A|B|C|8|9|10|X|Y\Z)\b)[\S\s]*?exit$";
string input = @"edit GoodMatch1 ;mode
Something Random
KeyWord_2 A B and C and also D E
Something Random
Something Random
KeyWord_3 1 A and 2 B
Something Random
KeyWord_1 1 2 and 3 and also 4 5
Something Random
exit";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}