const regex = /(?:(?:[^\s\d\x2e]+[\s\d\x2e]*)|(?:[\x2e\s\d]*[^\s\x2e\d]+))[\r\n]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:[^\\s\\d\\x2e]+[\\s\\d\\x2e]*)|(?:[\\x2e\\s\\d]*[^\\s\\x2e\\d]+))[\\r\\n]', '')
const str = `2222.22.22.22
asd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}