re = /(?:(?:[^\s\d\x2e]+[\s\d\x2e]*)|(?:[\x2e\s\d]*[^\s\x2e\d]+))[\r\n]/
str = '2222.22.22.22
asd'
# Print the match result
str.match(re) do |match|
puts match.to_s
end