using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\(\s*[A-z0-9_+-\/* ]+\s*(>=|<=|>|<|==|!=)\s*[A-z0-9_+-\/* ]+\s*\)$";
string input = @"( a + b >= a - g[i, j+d] )";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}