import Foundation
let pattern = #"^\(\s*[A-z0-9_+-\/* ]+\s*(>=|<=|>|<|==|!=)\s*[A-z0-9_+-\/* ]+\s*\)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"( a + b >= a - g[i, j+d] )"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}