$re = '/^\(\s*[A-z0-9_+-\/* ]+\s*(>=|<=|>|<|==|!=)\s*[A-z0-9_+-\/* ]+\s*\)$/';
$str = '( a + b >= a - g[i, j+d] )';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);