#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)[a-z]+\s\d+"
Local $sString = "hey 123" & @CRLF & _
"" & @CRLF & _
"hey 1" & @CRLF & _
"" & @CRLF & _
"a 3" & @CRLF & _
"" & @CRLF & _
"a 124" & @CRLF & _
"" & @CRLF & _
"tab 312" & @CRLF & _
"" & @CRLF & _
"newline" & @CRLF & _
"123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")