package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[a-z]+\s\d+`)
var str = `hey 123
hey 1
a 3
a 124
tab 312
newline
123
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}