$re = '/[a-z]+\s\d+/i';
$str = 'hey 123
hey 1
a 3
a 124
tab 312
newline
123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);