import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d|\\d,)(?=(?:[\\d,]+\\s)*(PLN|EUR|USD|CHF|GBP)(?:\\s*[\\d,]+\\s)*)(?=(?:PLN|EUR|USD|CHF|GBP)*\\s*((\\d+)(,?\\s?|.)(\\d{1,2}))\\s?(?:PLN|EUR|USD|CHF|GBP)*)";
final String string = "randomtext 1150,25 USD randomtext\n"
+ "randomtext USD 1150,25 randomtext";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}