$re = '/(?<!\d|\d,)(?=(?:[\d,]+\s)*(PLN|EUR|USD|CHF|GBP)(?:\s*[\d,]+\s)*)(?=(?:PLN|EUR|USD|CHF|GBP)*\s*((\d+)(,?\s?|.)(\d{1,2}))\s?(?:PLN|EUR|USD|CHF|GBP)*)/';
$str = 'randomtext 1150,25 USD randomtext
randomtext USD 1150,25 randomtext';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);