const regex = /(?<!\d|\d,)(?=(?:[\d,]+\s)*(PLN|EUR|USD|CHF|GBP)(?:\s*[\d,]+\s)*)(?=(?:PLN|EUR|USD|CHF|GBP)*\s*((\d+)(,?\s?|.)(\d{1,2}))\s?(?:PLN|EUR|USD|CHF|GBP)*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d|\\d,)(?=(?:[\\d,]+\\s)*(PLN|EUR|USD|CHF|GBP)(?:\\s*[\\d,]+\\s)*)(?=(?:PLN|EUR|USD|CHF|GBP)*\\s*((\\d+)(,?\\s?|.)(\\d{1,2}))\\s?(?:PLN|EUR|USD|CHF|GBP)*)', 'g')
const str = `randomtext 1150,25 USD randomtext
randomtext USD 1150,25 randomtext`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}