#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*\(([[:blank:]]*[[:alnum:]]*[[:blank:]]*\**[[:blank:]]*[[:alnum:]]*[[:blank:]]*,){5}[[:blank:]]*[[:alnum:]]*[[:blank:]]*\**[[:blank:]]*[[:alnum:]]*[[:blank:]]*\)"
Local $sString = "lc_checkout(int job, feature, version, nlic, flag, key )"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")