const regex = /^(?=.{6,30})\d+F?\d+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{6,30})\\d+F?\\d+$', '')
const str = `5436513685473651368435413845136854361541111
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}