import Foundation
let pattern = #"^(?=.{6,30})\d+F?\d+$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
5436513685473651368435413845136854361541111
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}