$re = '/^(?=.{6,30})\d+F?\d+$/';
$str = '5436513685473651368435413845136854361541111
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);