package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(.*?)\]`)
var str = `250000000000 bytes [250 GB]
400000000000 bytes [400 GB]
500000000000 bytes [500 GB]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}