re = /\[(.*?)\]/
str = '250000000000 bytes [250 GB]
400000000000 bytes [400 GB]
500000000000 bytes [500 GB]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end