const regex = /\[(.*?)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(.*?)\\]', 'g')
const str = `250000000000 bytes [250 GB]
400000000000 bytes [400 GB]
500000000000 bytes [500 GB]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}