using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(a|b)=(?:"")?(.*?(?=""?\s+\w+=|(?:""?)$))";
string input = @"a=""First Field"" b=SecondField c=""ThirdField"" a=""ThirdField"" e=SecondField f=SecondField b=""SecondField""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}