$re = '/(a|b)=(?:")?(.*?(?="?\s+\w+=|(?:"?)$))/';
$str = 'a="First Field" b=SecondField c="ThirdField" a="ThirdField" e=SecondField f=SecondField b="SecondField"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);