re = /(a|b)=(?:")?(.*?(?="?\s+\w+=|(?:"?)$))/
str = 'a="First Field" b=SecondField c="ThirdField" a="ThirdField" e=SecondField f=SecondField b="SecondField"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end