using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]{1,2}(:[0-9]{1,2}){2}(?=\sGMT)";
string input = @"located on 10/6/2015 5:18:14 GMT";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}