re = /[0-9]{1,2}(:[0-9]{1,2}){2}(?=\sGMT)/
str = 'located on 10/6/2015 5:18:14 GMT'
# Print the match result
str.match(re) do |match|
puts match.to_s
end